Zoom (Z) over-aggressive?

I’m having a heck of a time controlling the Zoom (Z/magnifier) as it appears to overzoom the area selected. If I select an area, it will overzoom into the area about 15-20%, and then I need to zoom back out and in again to get what I’m looking at. I’ve attached a small example to demonstrate:


I would think it would look at height and width combined, but it certainly overshoots both. Most all my other tools zoom to include both height and width

It fits the selected area to the window.

It respects the longest edge.

In your example it is fitting by width of the selected area.

I do see what you mean though.

What version of Acorn are you using? It looks like it might be the latest, but I’m not sure.

I’m trying to reproduce this on my end, but without any luck.

It does zoom in a bit more to the left than right, but the issue is really height and width. I’m comparing it with other tools like Sketch. It’d be great if Acorn were able to scale in the horizontally- and vertically-selected area, instead just one axis of it, which isn’t entirely what the user chose.

For instance, if the user is selecting a taller, vertical area, like designing a sidebar, Acorn still zooms in to the center of the selected width of that area, so they would need to manually zoom back out and reorient to look at the whole sidebar.

For the record, I’m on what I believe is the latest: Version 6.6.3 (13830). It’d be great if it’s just a user setting/error

1 Like

I think I found the problem. Is this on a 1x display, or a 2x display?

I believe it would be on a 1x display … I’m using a dual external setup running on older Dell (ssssshhh…) displays at work primarily. Unfortunately I’m home now on the weekend so I can’t check.

Can you try the latest build and let me know how it works out for you now? You can grab it from here:

Weird - I know I replied, but I don’t see it here.

Anyway, the latest build worked great. Thanks for the fast fix (and again, apologies for my misfiring)

1 Like