Write Images Using Source Folder

Is there a way to write images using the original images source folders as new folder locations?

shot_01 / image 1.raw (—>) shot_01 / image 1.jpg

I think it should look like this. source folder/file name

Thank you

1 Like

It isn’t currently possible, but I can look into it.

I just want to make sure I’m getting this right- you don’t want the images written back to the same folder, you want them written to new folder, which is the same name as the folder the image came from? For example:

/My Originals/Folder A/Image1.raw
to
/Processed/$sourceFolder$/$imageName$.jpg
aka:
Processed/Folder A/Image1.jpg

is that right?

-gus

That is exactly right.

In beta 5, I added “Source Folder” as a token option for text watermarks and file names. So try that out, and let me know if it works for you or not.

1 Like

I just want to write to the same folder :wink:

It’s on the list, and is probably our #1 request right now.

1 Like

Is there any progress on either writing to the same folder or writing to a new folder using the same directory structure? It would significantly improve the workflow for our team.

Not yet. It’s a little tricky and there’s somethings we have to get in place first. Hopefully it’ll happen soon though.

1 Like

From the release notes on the latest build (http://flyingmeat.com/download/latest/#retrobatch):

  • New “Source Folder” token for the Write node, can be used to write an image back to the same folder it was read from. The previous token of the same name has been renamed to “Source Folder Name”.

Try it out- let me know what you think!

1 Like

This is great! Exactly what we need. Thank you!

Can you please explain how to use it? I added the token to the File name field but that will only create a subfolder “SourceFolderPath” inside my downloads folder.

The SourceFolderPath bits only kick in when there’s no Folder: option set. This should probably be considered a bug on my part (sorry).

So to fix it, remove your write images node, re-add it, and don’t pick an output folder when prompted. Let me know if that doesn’t do the trick.