Using Acorn in Mac Photos

When I try to edit Acorn within Photos, I get a very small, 120 by 120 or so pixels to edit. I do not get the full photo! I have no clue what is happening. Other photo editors work just fine. I don’t see anything in either Preferences that would seem to have anything to do with this. Bug? or??

It sounds like Photos is giving Acorn a very small image for some reason - Acorn will take whatever it’s given and open it up.

Can you tell me how you are sending the image to Acorn from Photos? Are you using the “Edit In” menu, or something else?

I am trying to use Extensions to bring photo into Acorn from Photos. The file name that it does show is that long string that one will see for what I assume is the preview in Photos library. I have tried some jpegs from Photos to Acorn and they seem to work. But none of my RAW photos will. If I check by opening a RAW file in Acorn alone, works just fine. Might be issue from Photos side?? I really don’t want to go back and do the Photos Library again, even if there are not that many photos in it. Thanks!

What about if you use the Image ▸ Edit With ▸ Acorn menu item in Photos? Does that work OK?

An iPhone dng, edited with extensions shows this file type
Pixelmator Pro, wants to process RAW, shows as layer, no file type
Luminar AI , processes, (kinda slow) and ready to edit , no file type
Note here that it also applies lens correction
Acorn, shows that 30 character long file name in jpg, looks darker too, canvas size is 4032x3024, edits stick

HEIC files
In Acorn, shows that 30 character jpg, edits as expected, and doing a save and close and back to Photos and edits stick. But, it looks like there has been editing done by either Acorn or Photos, the jpg does NOT look like the original file in the Photos display.

And this
I have switched to a Nikon, NEF files, and this is where the Extensions edit attempt in Acorn results in the 160x120 pixel jpg to show up!

And even worse?
I have some Sony AWR photos too. Using Acorn from Extensions says it can’t find the 30 character jpeg file.

Several days ago, I added a number of photos, eliminated a bunch and then noted that my system seemed laggy. Upon checking with Activity Monitor, it was doing its’ best. There was an item that had the phrase or something. This continued to run for some time. So, suspicion, the Photos library is not working the way Acorn expects it to???

I think this is more than what you want. I have an iMacMini late 2012
2.3 GHz Quad-Core Intel Core i7 processor, 8 GB 1600 MHz DDR3, Catalina 10.15.7 version.

Hope this helps.
Charles J

Just one more question (for now) - what version of Acorn are you using?

There was an issue with RAW files a while back I think, but I thought we got that fixed.

Also- our “office” is going to be closed till the new year, so I might not be able to take a good look at this for a week or so.

I’m using 7.1.1 from Apple Store
No big need for haste!
Happy New Year

Hello, I’m back!

I got the dark preview to happen with Acorn 7.1.1, and it only seems to be happening with NEF files, but once I hit the OK button then it opens up fine.

Can you tell me if opening a .nef file from the Finder causes it to open up super small in Acorn for you? IE- do this without bringing the Photos app into the equation.

Well, I think I know what the problem is, me! I have been experimenting with different apps trying to find one that will act as a DAM and a photo editor and produce the results I would like to see. I suspect that what happens is that in trying the same sets of photos with different DAM/catalog/ whatever you call them, things have been mucked up. Any app that has any kind of catalog/DAM that touches a file will add information somewhere somehow. I suspect that corruption is happening which your app is picking up, even if others do not. And I have noted now that the Open With command if Finder will NOT show Acorn and a couple of other photo editing apps that I have. So something strange. :frowning_face:

Well, I just tried taking a new NEF photo, brought straight into Photos, went to Edit, used Acorn extension, and got just the preview (I assume), which showed that Photos file name thing, and as a small photo, maybe dimensions in the 120 pixel range? So, something in NEF? Now, copy same photo to Desktop, drop icon onto Acorn, photo opens as it should with correct photo name and .NEF extension.

Using Edit With from Photos, photo shows as a .tiff, and full size.
This is above my pay grade!

And solved?? I was using the App Store version. I have just deleted that and installed the trial version from your web page. It seems to work as advertised with NEF files.

Alright, I got that to reproduce with the App Store version. Very, very strange! I’ll get it figure out. Thanks for reporting this!

FWIW, I’ve got this fixed for the next release of Acorn, which will most likely be 7.2.3.

Thanks for reporting this!