Trouble getting started


Just bought Retrobatch, but I’m having a problem creating a workflow that works. I took nodes out until it did work, and here are the results:

Prompt for files > Change Color Profile > Write images. I set the folder in the Write I mages node and everything, checked “open folder when export finishes.”

Not working:

Adding either Scale (to fixed height) or Set Specific Metadata, or both, to the middle of that workflow. What happens is the info window tells me it processed x number of pixels, and the output folder opens in the Finder, but it is empty.

Can anyone help? Thanks!

FWIW: I recreated this workflow and it works now, not sure what I did differently other than not hardcoding a destination folder in Write Images…

Do you still have the workflow that was causing issues? I’d love to take a look at it.

I’m a new user so I can’t upload attachments :zipper_mouth_face:

I will send it via email to support@flyingmeat, referencing this thread.


1 Like

Documenting for future idiots such as myself - Gus pointed out that the problem was that all my arrows between nodes were not pointing in the right direction. Hadn’t noticed that this was a thing in Retrobatch!

Even as an experienced user, I think it takes way too much effort to get the arrows pointing the correct way.

I am forever breaking workflows apart and moving nodes around in “just the right way” to get the arrows to point the correct way

Should they default to left to right and top to bottom?

I organise my workflows vertically FWIW.

Yes, the default from left to right and top to bottom. I designed it for left to right, but doing it vertically should work just the same. There’s also the option for manual connections in the prefs, if the auto-connecting nodes isn’t your thing.

I hope it’s OK to keep posting about this issue in this thread.

Just moving all the nodes around in one big group results in the arrows changing direction. I’ll send a proper bug report about this.

It’s fine to keep posting. I’d love to see that bug report, since the arrows should keep going the right direction.

Have sent a few now!

Yes you have :slight_smile: (And they are all good)