Problem when converting jp2 files


#1

Hello,

just a quick feedback: When working on JPEG2000 files (extension .jp2) Retrobatch truncates the file to 0 bytes. That happens when writing the output to a new folder as well as when the original file is changed in place.

Workflow:
-> Read Folder
-> Set Specific Matadata
… Add: IPC
… Date Time Original
-> Write Images

Seems the file format is not understood and not skipped either.

Wolf


#2

Hello @Wolf

Date Time Original is under the EXIF category- did you mean that?

And can you tell me if the problem happens with all images you try, or just specific ones? And if you disable the metadata node, does it work?

And finally, what version & build of Retrobatch are you using? I just tried on my end with the latest build (http://flyingmeat.com/download/latest/#retrobatch) and it worked out OK.

thanks,

-gus


#3

Hello ccgus,

I’m testing with version 1.0b5 (452).
Update: Have downloaded 1.0b6 (483) with the same result.

The Date-Field is IPTC > Date Created
My bad, I got the field name wrong in the first post; but it doesn’t work with EXIF > Date Time Original either…

I’ve run the tests on different files and different folders to make sure its not a one time thing (or maybe a bad file).

I’d love to attach a demo file or two… but thats not possible here. Let me try to find an upload service and post a link here…
Maybe this works:
https://1drv.ms/u/s!AhpAVwZHPVxQnqErp1FkhzWhLs2TJw
https://1drv.ms/u/s!AhpAVwZHPVxQnqEsW1hymJtil1VAhQ

Regards

Wolf


#4

Update: Just for fun, I’ve exchanged the Metadata change to a Watermark filter. That works. :slight_smile:

But changing any Metadata (I’ve also tried EXIF > User Comment) truncates the file.


#5

OK, I was able to reproduce it. I didn’t have the write node set to “keep original type”. Let me see if I can find out what’s going on


#6

OK, it’s fixed in the latest builds. The problem was that RB was assuming JP2K files could have their metadata rewritten without re-encoding the file. This isn’t the case, at least with the functions that Apple provides to us in MacOS. So I got the fix in the latest build which you can grab here:
http://flyingmeat.com/download/latest/#retrobatch

I’ll see if I can bug Apple at WWDC about adding support for JP2K files, or failing that finding some other way to do it.