Please can I just erase a few pixels?

I’m trying to do something I’m pretty sure I’ve done for years without problem in Acorn – simply erase some pixels on a layer (in order to let something from another layer show through). Sometimes it works – see the left side of first image. Other times it decides to garbage up the works with a mask – or mask – layer – or who knows what. Regardless, it renders the image completely unusable – see the right side…

In the second photo, you can see that it’s not creating a new layer, simply destroying the existing one:

And in the third, you can see what happens after clicking on one of “mask mess” areas:

Sorry about the problems. Can you tell me a little about this image (or give me a screenshot of the palette when you press the ‘v’ key twice? That’ll bring up some info including pixel dimensions and bit depth that’ll help me diagnose).

And can you tell me what kind of Mac hardware you’re using, as well as what version of MacOS you’re running?

This looks like some sort of rendering problem, but I’ve never seen things go bad like this (usually there will be fills of black where things go wrong, not strange blues and greens).

One other thing to try- what happens if you change the Renderer: option in the Fussy Stuff tab of the Preferences? (You’ll have to close and re-open your image for the new renderer to kick in).

Changing the pixel processing profile appears to fix the problem – changing just the renderer worked a little in OpenGL (even though any of the options show in Info as OpenGL) before the attack of the blocks began again.

After fiddling with settings, I set the renderer back to Metal (default) and pixel profile to none, and now it’s working fine (if slow).


Thanks for getting back to me! I’ll have to get my hands on one of these boxes to test with.

Hi Gus, not starting a new subject since apparently this is my “box” issue, even with 16GB of RAM. Acorn is simply unworkable at this point: lag is typically 10-20 seconds, and even a simple action like making a circle with a brush overwhelms it:


It’s a shame. Enthusiastic as I am about Acorn’s compact size (my needs are relatively simple), it can’t even do the basics at this point. I should mention, too, that getting it to even do this fragmentary brush strokes requires “fussy” tweaking from the default settings. This is a simple brush circle after a fresh reinstall, with no tweaking:

Please let me know if you get this sorted out. Except for the goofy arrows, Acorn has long been my go-to app for basic photo and markup needs.

I wonder if something in the graphics driver has become corrupt somehow. Have you restarted your Mac at all since these problems started showing up?

I have. Also

  1. changed the screen resolution, which is supposed to reset the GPU;
  2. reset PRAM;
  3. reset SMU;
  4. started in safe mode (joke!)

No improvement whatsoever.

Do you remember what the last version of Acorn was that worked fine for you? Maybe I can narrow down what changes occurred. Here’s some links to previous versions if that helps as well:

The problem exists only in 6.3. I can send screen shots if you’re interested.

No screenshots necessary- I believe you!

That’s really interesting! If you have time, can you grab a couple more builds to see if they have the same issue? This will help me narrow down where the bad change was made.

There’s also the public beta version of 6.5 up here as well:


Well then you’ll just salivate over this :smiley:

Thanks for the links to earlier versions. Acorn once again rules on my doddering Mac Mini!

Awesome, so the problem occurred after build 13263. Did you try any of the other builds? And if yes, did they work OK as well?

I have tried every one you sent a link to. As the images show, the problem first occurred with build 13325.

Oh wow, I didn’t see how tall that image was! The preview was only showing 13264 for me. Thanks, I’ll do some diffs and see what changed.

Here’s something to try. Quit Acorn, open up (located in the Utilities folder) and paste in the following line and press enter:

defaults write com.flyingmeat.Acorn6 useBrushEngine1 1

Then try your brushing and let me know what happens at that point.

We’ve got this fixed for the next release of Acorn, as well as in the latest builds which you can grab from here:

Excellent, thanks! Once I did the terminal command (which I just now saw), it worked, but not before.