Opening Raw files

I’m not sure if I’m doing something wrong here but if I open a raw file directly into Acorn, the initial screen displays the image extremely dark. If I then click ‘OK’ to open it in the main program, it displays normally. This means the raw conversion window is unusable.
Raw files: Canon .CR2 files from an EOS 60D
Acorn 7.4.4 - App Store version.
MacOS Ventura 13.6.7

Hello, and welcome!

Can you send a copy of the image to support@flyingmeat.com so we can check it out? If I can get the problem to reproduce on my end I can most likely get it fixed.

-gus

Thanks for the speedy response, Gus. I’ve emailed you the file.

Thanks

Gareth

Update: It seems to be specific to my set-up. I opened the same file using the same version of Acorn on my MacBook Pro (MacOS Catalina 10.15.7) and it opens in the ‘raw’ window just fine!

Thanks for sending in the file. There does seem to be something interesting about it that makes things go a bit wonky when using OpenGL for rendering the image. Here’s something to try:

Open up Acorn, and open up the Acorn ▸ Settings… window
Navigate to the Fussy Stuff tab, and change the Renderer: setting to Metal if it isn’t already.
Try opening up your RAW image, and let me know what happens.

-gus

Thanks for the reply, Gus.
It was already set to render using Metal.
Changing it to OpenGL just gives a blank display - which then opens correctly in the main program.
Changing back to Metal gives the ‘dark’ display as before.

Gareth