I'm not seeing the transparency checkerboard

For some reason, I can’t see the checkerboard pattern that represents transparency. Supposedly transparent areas show as white. I opened a PNG file and tried to delete the white parts, expecting to see checkerboard in its place, but it stayed white. I added a transparent layer below the image (the checkerboard shows on the thumbnail in the Layers palette) and tried to delete or erase the white areas; still white. I tried it with a JPG image. I even created a new image with a transparent background, and it just shows white. I can see the checkerboard underneath tools, like in the circle of the eraser or the brush, but I can’t make the whole area look and stay transparent.

Sorry about the problem!

Can you tell me a little bit about the Mac you’re running on? What model Mac it is, as well as what version of MacOS you’re running? I’ve not ever seen this problem before, but maybe with a bit more info I can figure out what’s going on.

Also- if you change the Renderer: option in the Preferences ▸ Fussy Stuff tab to “OpenGL”, does the problem still occur?



Hi, Yeah, it’s a weird one. I’ve been using Acorn for many years and have never seen this before. I did recently spring for Acorn 6 (I’m on 6.3.1), and I can’t say for sure I’ve seen the expected behavior from 6–I don’t use the app all that often.

I’m on a 2010 Mac mini running High Sierra 10.13.6.

Changing the Renderer option didn’t make a difference.

I’ve attached a screenshot that shows what I see. It’s a black-and-white JPG with a transparent layer underneath. You can see where I’ve erased across the top layer and would expect to see the checkerboard underneath, but don’t, though I see the checkerboard under the eraser tool itself.

More weirdness: when I tried to take the screenshot using Shift-Cmd-4, as soon as I highlighted the window I saw the image the way I would expect, with a checkerboard in the entire erased area. I had to use Grab to get the screen the way I saw it while working in Acorn.

Thanks–any suggestions welcome.

The screenshot you posted- that’s the way you’re seeing it currently? You’re using Grab to to make it?

It looks like you opened a JPEG image and then added a layer below it. And then you erased some of the layer that was created from the JPEG and I can see the checkerboard coming through, so that’s working as expected.

JPEG images don’t have transparency in them. Maybe that’s where the confusion is coming in? Or is it that the screenshot you posted isn’t showing what you’re seeing?


Yes, I did as you describe: opened a JPEG, added a transparent layer below it just for demonstration purposes, erased some of the JPEG’s layer. And in fact the screenshot you’re describing is not what I see. BUT I think the screenshot you’re describing is what’s “really happening.” You see the checkerboard under the entire swoosh I drew, right? I don’t–that’s all white for me except for the circle right under the eraser tool. But I just messaged that screenshot to myself and looked at it on my phone, and on the phone I see the checkerboard under the entire swoosh (even though in Messages on my Mac, I see just the white).

So I guess this is some weird shit my Mac is doing. If you have any suggestion what that might be, I’ll welcome it. Otherwise, thanks for looking into it.

Well, first up I’d reboot and see if that clears things up.

Next, I’d check and see what color profile you have your monitor set to. If you open up the System Prefs ▸ Displays pane, and change the Color profile to something like sRGB- does that work out?

I’m also curious if the same problem happens in Acorn 5 if you still have it around. It sounds like the background checkerboard color is getting washed out, and it’s the same values in Acorn 5 as it is in v6.

I tried rebooting the first time it happened, but it can’t hurt to try again. And the same thing happens in 4.5 (I never bought 5).

BUT thanks for the suggestion of changing color profiles. I have no idea what I had it set on, but changing it to my most recent calibrated profile for this monitor made the checkerboard show up. Thanks very much for your help.