Clipboard input broken?

I have tried a number of images on the clipboard as input: They all result in broken link in the preview and will not process any further: Here is what I see:

Any thoughts?

  • The clipboard.png file that serves as the intermediary placeholder image never loads and results in the broken link seen above.
  • I’ve tried copy / paste / refresh from web images, local images in preview, image selections on Adobe Photoshop

Mac High Sierra 10.13.6

Thanks for spotting this! I can confirm this on my end- the workflow runs correctly but the Preview is putting up a bad image. I’ll get it fixed.


Thanks, Gus, it’s an awesome tool and just what I am looking for to speed up my workflow in image crops for podcast production. Having the clipboard option will save a ton of time for me.

Let me know if there is a beta version to download once you identify and fix, hope it’s an easy one…

Any thoughts on how long something like this would take?

With appreciation, JB

I just did a bit of work on the clipboard bits- you can grab a beta of it from here:

Let me know how it works out!

The image thumbnail shows up, but then the image does not appear to get passed along to other steps in the workflow…

OK- Looks like there was a bad interaction with the scale node and the clipboard node. A new build with a fix has just been put up:

I tested with the same workflow as you, so you shouldn’t run into any more issues. But if you do, let me know!


View this video here:

OK, so the thumbnail never updates correctly (and you’d like the workflow to automatically preprocess when a new image is put on the clipboard).

Can you confirm that the workflow runs correctly though?

I have an identical workflow that runs correctly when the input is a single file selection, instead of the clipboard. Is that what you mean?

And yes, there is a step where I want to be able to modify the crop by changing the XY axis for each image before saving…

What I mean is, even though the preview and thumbnail doesn’t update correctly- does the workflow copy from the clipboard and write to your desktop as expected?

Actually, upon further investigation, the clipboard issue is resolved.

The issue I am seeing now seems to have nothing to do with the clipboard now…

I am noticing that if I start a brand new workflow from scratch, and add steps, the steps no longer automatically connect to each other. So I can start with “Read individual file”, but no matter what additional steps I add, and no matter how I drag them into close proximity of the starting step, the additional shapes never connect to the original one.

Now, the manual connection using the [ctrl]-[drag] method still works, it’s just an issue with the auto connections now, so I can work around that.

Brilliant…I can record another video about the proximity behavior tomorrow if you like.

The pref for the manual connection means if you have it turned on, then proximity linking is turned off. So it’s one or the other, not both.

More good news on the clipboard front though- I’ve got a build coming soon that’ll poll for changes in the clipboard every few seconds. So if your clipboard changes, then nodes will update the preflight count.